summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 10 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a05629c8494..5a259948863c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=libklvanc-git
-pkgver=r434.d474cfc
+pkgver=1.6.0.r8.g3365db3
pkgrel=1
-pkgdesc='Library which can be used for parsing/generation of Vertical Ancillary Data (VANC) (git version)'
+pkgdesc='Library for parsing/generation of Vertical Ancillary Data (VANC) (git version)'
arch=('x86_64')
url='https://github.com/stoth68000/libklvanc/'
license=('LGPL')
-depends=('ncurses')
-makedepends=('git' 'zlib')
+depends=('glibc')
+makedepends=('git')
provides=('libklvanc')
conflicts=('libklvanc')
source=('git+https://github.com/stoth68000/libklvanc.git')
@@ -16,30 +16,22 @@ sha256sums=('SKIP')
prepare() {
cd libklvanc
-
./autogen.sh --build
}
pkgver() {
- cd libklvanc
-
- # git, no tags available
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C libklvanc describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^vid\.obe\.//;s/^v//'
}
build() {
cd libklvanc
-
- ./configure \
- --prefix='/usr' \
- --enable-shared='yes' \
- --enable-static='no'
-
+ ./configure --prefix='/usr'
make
}
package() {
- cd libklvanc
+ make -C libklvanc DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" install
+ # the -debug package is preventing binary executables from being stripped
+ strip "$STRIP_BINARIES" "${pkgdir}/usr/bin"/*
}