summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57c707d746cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: MobiusHorizons <codemobius@gmail.com>
+pkgname=libmacaroons
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Libmacaroons provides flexible authorization credentials that support decentralized delegation, attenuation, and verification, and is used by HyperDex."
+url="https://github.com/rescrv/libmacaroons"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=()
+makedepends=('wget' 'gcc')
+conflicts=()
+replaces=()
+backup=()
+source=("http://hyperdex.org/src/${pkgname}-${pkgver}.tar.gz")
+md5sums=('99e86f7813366f1d17bb4164bab63d7a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: