summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8695f7f5d911..04ac1d0c8ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=libmodulemd
-pkgver=2.6.0
+pkgver=2.7.0
pkgrel=1
pkgdesc="C Library for manipulating module metadata files"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ depends=('glib2' 'libyaml')
makedepends=('gobject-introspection' 'gtk-doc' 'meson>=0.47' 'python-gobject')
optdepends=('python-gobject: for python bindings')
source=("$url/releases/download/$pkgname-$pkgver/${pkgname#lib}-$pkgver.tar.xz")
-md5sums=('d0c7ce321f83640b674a733d5a7de5f3')
+md5sums=('6a56a944e2ddb8e9d87ebaef52b3245a')
prepare() {
mv "${pkgname#lib}-$pkgver" "$pkgname-$pkgver"
@@ -17,12 +17,8 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- arch-meson build -Ddeveloper_build=false -Dbuild_api_v1=true
+ arch-meson build -Ddeveloper_build=false -Dwith_py2_overrides=false
ninja -C build
-
- # Trick to be able to link binaries against either v1 or v2 API
- sed -e '/Libs:/ s/-lmodulemd/&-2.0/' \
- -i build/meson-private/modulemd-2.0.pc
}
check() {
@@ -34,14 +30,8 @@ package() {
cd "$pkgname-$pkgver"
DESTDIR="$pkgdir/" ninja -C build install
- # Trick to be able to link binaries against either v1 or v2 API
- ln -sf "$pkgname.so.1" "$pkgdir/usr/lib/$pkgname.so"
- ln -sf "$pkgname.so.2" "$pkgdir/usr/lib/$pkgname-2.0.so"
-
install -Dp -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
install -Dp -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
-
- chmod 644 "$pkgdir/"usr/share/gtk-doc/html/modulemd-[12].0/style.css
}
# vim: set ft=sh ts=4 sw=4 noet: