summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f824cec8ebb0..95501ba761b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
-# build for gimp-git, with gegl support
pkgname=libmypaint-git
-pkgver=1.1.r591
+pkgver=1.1.r640
pkgrel=1
-pkgdesc="a library for making brushstrokes which is used by MyPaint and other projects"
+pkgdesc="a library for making brushstrokes which is used by MyPaint and other projects, with GEGL support"
arch=('i686' 'x86_64')
url="http://mypaint.org/"
license=('ISC')
-depends=('gegl' 'babl' 'json-c')
-makedepends=('scons' 'python')
+depends=('gobject-introspection' 'json-c' 'gegl')
+makedepends=('intltool' 'python')
source=('git+https://github.com/mypaint/libmypaint.git')
md5sums=('SKIP')
build() {
- true
+ cd "$srcdir/libmypaint"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-gegl
+ make
}
package() {
cd "$srcdir/libmypaint"
- scons prefix=/usr enable_gegl=true use_sharedlib=yes \
- --install-sandbox="$pkgdir" "$pkgdir"
-
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- cp COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
pkgver() {