summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 154d0cd134a9..8caa3b7af776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,12 +15,12 @@ source=("$pkgver.tar.gz::https://github.com/pali/libopenaptx/archive/$pkgver.tar
sha512sums=('7c7f515585ed41cd276cd3141037ce21e3ebdb713dc932bcdb33320d9910c734bc81e581e2c09b3399b3516c789e5da7128fdab5ab6b5e4f42a86b6ac6d3f28c')
pkgver() {
- cd "${pkgname%-git}"
+ cd "${pkgname%-pkgver%}"
git describe --tags | sed 's/-/+/g'
}
build() {
- cd "${pkgname%-git}"
+ cd "${pkgname%-pkgver%}"
make CPPFLAGS="$CPPFLAGS" \
CFLAGS="-O3 -mavx2 $CFLAGS" \
LDFLAGS="$LDFLAGS" \
@@ -28,6 +28,6 @@ build() {
}
package() {
- cd "${pkgname%-git}"
+ cd "${pkgname%-pkgver%}"
make PREFIX=/usr DESTDIR="$pkgdir" install
}