summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84bf69c18ce0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+
+pkgname=libpamac-git
+_pkgname=libpamac
+pkgver=1.1.3.r6.g25b0dba
+pkgrel=1
+pkgdesc="Library for Pamac package manager based on libalpm - git version"
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://gitlab.manjaro.org/applications/libpamac"
+license=('GPL3')
+depends=('pacman>=6.0' 'pacman<6.1' 'appstream-glib' 'polkit' 'archlinux-appstream-data-pamac')
+makedepends=('gettext' 'itstool' 'vala' 'meson' 'ninja' 'gobject-introspection' 'xorgproto' 'asciidoc')
+options=(!emptydirs)
+conflicts=('libpamac-aur' 'libpamac-full' 'libpamac-full-dev' 'libpamac')
+source=(git+https://gitlab.manjaro.org/applications/libpamac.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -c2-48
+}
+
+build() {
+ cd $_pkgname
+ mkdir -p builddir
+ cd builddir
+ meson setup --prefix=/usr --sysconfdir=/etc --buildtype=release
+ # build
+ ninja
+}
+
+package() {
+ backup=('etc/pamac.conf')
+ cd $_pkgname
+ cd builddir
+ DESTDIR="$pkgdir" ninja install
+}
+
+#vim:set ts=2 sw=2 et: