summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0de601b48a9..8fbe32e066c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Felix Kauselmann <licorn@gmail.com>
pkgname=libpdfium-nojs
-pkgver=4389.r1.157601b9b9
+pkgver=4577.r0.60a7195a9b
pkgrel=1
pkgdesc="Open-source PDF rendering engine."
arch=('x86_64')
@@ -49,6 +49,12 @@ prepare() {
# git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=beta | cut -d'.' -f 3)"
# git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=dev | cut -d'.' -f 3)"
+ # Fix missing string headers for GCC + libstdcc compilation, but only for affected version
+ if [ `git rev-parse --abbrev-ref HEAD` == 'chromium/4577' ]
+ then
+ git cherry-pick -n 7a6289c
+ fi
+
# Extract build repo revision needed from DEPS file and do a checkout
cd "$srcdir/pdfium/build"
git checkout $(awk '/build_revision/ {print substr($2,2,40)}' $srcdir/pdfium/DEPS) -q