summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc90059b6405..a0ffe6e5a3eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: twa022 <twa022 at gmail dot com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: twa022 <twa022 at gmail dot com>
pkgname=libpri
-pkgver=1.6.0
+pkgver=1.6.1
pkgrel=1
pkgdesc='library that encapsulates the protocols used to communicate over ISDN Primary Rate Interfaces'
-arch=('i686' 'x86_64')
-url='http://www.asterisk.org/'
-license=('GPL')
-depends=('dahdi')
-source=("https://downloads.asterisk.org/pub/telephony/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7225ea7ec334a115f9dc08e71f55589c38cb4e00b13964cd2f08cc4e6123e3f6')
+arch=(x86_64 i686)
+url="https://github.com/asterisk/$pkgname"
+license=(GPL-2.0-only)
+depends=(dahdi)
+_archive="$pkgname-$pkgver"
+source=("$url/archive/$pkgver/$_archive.tar.gz")
+sha256sums=('c38ea1b5a90a6a7a38d57fcb58f47f14d865468acf9e2e1ef0dc76e257755c7a')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make
+ cd "$_archive"
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "$_archive"
+ make DESTDIR="$pkgdir" install
}