summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65a3dc1650bb..4c90e9bb5431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: David McIlwraith <archaios at archaios dot net>
pkgname=libqcow
-pkgver=20120522
+pkgver=20150105
pkgrel=1
pkgdesc="Library and tools to support QEMU copy-on-write image format (QCOW, QCOW2), including a FUSE-based mount utility"
-url="http://code.google.com/p/libqcow/"
+url="https://github.com/libyal/libqcow/"
arch=('i686' 'x86_64')
license=('LGPL3')
depends=('fuse' 'openssl')
-source=(http://libqcow.googlecode.com/files/$pkgname-alpha-$pkgver.tar.gz)
-md5sums=('159703e5c34736d4fc38a509c62de1b9')
+makedepends=('zlib' 'openssl' 'python')
+source=("https://github.com/libyal/libqcow/archive/$pkgver.tar.gz")
+sha256sums=('1c93bb151506ecaf7a681a24444f2538f6541b700f4a29f39d536dc988895789')
build(){
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr
- make
- make DESTDIR=$pkgdir install
+ cd $srcdir/$pkgname-$pkgver
+ ./synclibs.sh
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-python --enable-verbose-output --enable-debug-output --enable-wide-character-type
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}