summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f1752f94a05..69b035c08308 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64 aarch64)
url="https://github.com/quotient-im/libQuotient"
license=("LGPL2")
-depends=("qt5-base" "qt5-multimedia" "qtkeychain-qt5")
+depends=("qt5-base" "qt5-multimedia" "qtkeychain-qt5" "libolm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
@@ -35,11 +35,12 @@ prepare() {
build() {
cd "build"
- Quotient_ENABLE_E2EE=ON cmake ../${pkgname} \
+ cmake ../${pkgname} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=1
+ -DBUILD_SHARED_LIBS=1 \
+ -DQuotient_ENABLE_E2EE=ON
make
}