summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d892d2805c1..d5af2d86028d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,27 +33,22 @@ pkgver() {
git describe --tags | sed -e 's/-/_/g'
}
-build() {
+prepare() {
cd "${srcdir}"
msg "Connecting to GIT server...."
- if [ -d ${_gitname}/.git ] ; then
- cd "${_gitname}"
-
- # Change remote url to anongit
- if [ -z $( git branch -v | grep anongit ) ] ; then
- git remote set-url origin ${_gitroot}
- fi
-
- git pull origin master
+ if [[ -d ${_gitname} ]] ; then
+ cd "${_gitname}" && git pull origin master
msg "The local files are updated."
else
git clone ${_gitroot} ${_gitname}
fi
msg "GIT checkout done or server timeout"
- msg "Starting make..."
+}
+build() {
+ msg "Starting make..."
cd "${srcdir}/${_gitname}"
export CPPFLAGS="-std=c++0x"
qmake-qt4 librecad.pro