summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1e7bac7c4f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bruno Bollos Correa <bollos@outlook.com.br>
+pkgname=libremines
+
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A Free/Libre and Open Source Software Qt based Minesweeper game available for GNU/Linux and FreeBSD"
+arch=('x86_64')
+url="https://github.com/Bollos00/LibreMines"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'hicolor-icon-theme' 'qt5-svg')
+makedepends=('cmake')
+provides=('libremines')
+conflicts=('libremines')
+source=("LibreMines-$pkgver.tar.gz::https://github.com/Bollos00/LibreMines/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('5b444f75b079e5b0e4e1abe2410394bd8b2d2db67c35d2f804d7e174f39abae8')
+
+
+build() {
+ cd $srcdir/LibreMines-$pkgver
+ mkdir builddir && cd builddir
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $srcdir/LibreMines-$pkgver/builddir
+ make DESTDIR="$pkgdir" install
+}