summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 329372484ef6..8a3e362444aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
pkgname=librepo
pkgver=1.9.6
-pkgrel=1
+pkgrel=2
pkgdesc="Repodata downloading library"
arch=('i686' 'x86_64')
url="https://github.com/rpm-software-management/$pkgname"
license=('LGPL2.1')
-depends=('curl' 'glib2' 'gpgme' 'libxml2' 'zchunk>=0.9.11')
+depends=('curl' 'glib2' 'gpgme' 'libxml2' 'openssl' 'zchunk>=0.9.11')
makedepends=('cmake' 'python')
checkdepends=('check' 'python-flask' 'python-nose' 'python-gpgme' 'python-pyxattr')
optdepends=('python: for python bindings')
-source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('99a0584d040975cf9ead08df62d399a4')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "$pkgname-1.9.6-fix-segfault-with-zck-repodata.patch::$url/commit/0b15c58.patch")
+md5sums=('99a0584d040975cf9ead08df62d399a4'
+ '75feff80c0fb7aa8e882d5551e8ff745')
prepare() {
cd "$pkgname-$pkgver"
rm -rf build
mkdir build
+
+ # Fix segfault when downloading zck repodata files
+ # (i.e: with Fedora >= 30 repositories)
+ patch -p1 -i "$srcdir/$pkgname-$pkgver-fix-segfault-with-zck-repodata.patch"
}
build() {