summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b1b3f7d5895..8548bd84a45e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
-# Maintainer : Johnathan Jenkins <twodopeshaggy@gmail.com>
-# Contributor: prettyvanilla <prettyvanilla@posteo.at>
+# Maintainer: Mike Polvere <mic.tjs@gmail.com>
+# Contributor: Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: prettyvanilla <prettyvanilla@posteo.at>
# Contributor: almostalive <almostalive2003 at gmail dot com>
pkgname=libretro-genesis-plus-gx-git
-pkgver=1366.5c515fb
+pkgver=1459.7856b72
pkgrel=1
-pkgdesc="libretro implementation of Genesis Plus GX. (Sega Master System/Sega Game Gear/Sega Mega Drive/Sega Genesis/Sega CD)"
+pkgdesc='Sega 8/16 bit emu - Genesis Plus (enhanced) port for libretro (Sega MS/GG/MD/CD)'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-groups=('libretro')
-url="https://github.com/libretro/Genesis-Plus-GX"
-license=('custom')
-conflicts=('libretro-genplus-git')
-depends=('zlib' 'libretro-core-info')
-makedepends=('git')
-
_libname=genesis_plus_gx_libretro
_gitname=Genesis-Plus-GX
+url="https://github.com/libretro/${_gitname}"
+license=('custom')
+groups=('libretro')
+depends=('glibc')
+makedepends=('git')
source=("git+https://github.com/libretro/${_gitname}.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "${_gitname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
build() {
- cd "${_gitname}"
- make -f Makefile.libretro
+ cd "${_gitname}"
+ make -f Makefile.libretro
}
package() {
- install -Dm644 "${_gitname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
-}
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_gitname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}