summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 29 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b05f9a3e07e..74fe5059d917 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,45 @@
-# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
-
-pkgname=libretro-neocd-git
-pkgver=80.b795a80
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Oliver Jaksch <arch-aur at com-in dot de>
+_pkgname=libretro-neocd
+pkgname=$_pkgname-git
+pkgver=r145.2070f52
pkgrel=1
-pkgdesc="Neo Geo CD emulator for libretro"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+pkgdesc="SNK Neo Geo CD core"
+arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/libretro/neocd_libretro"
license=('LGPL3')
groups=('libretro')
-depends=('zlib' 'glibc' 'libretro-core-info' 'flac' 'libogg' 'libvorbis' 'zlib')
-makedepends=('git' 'cmake')
-
-_libname=neocd_libretro
-_gitname=neocd_libretro
-source=("git+https://github.com/libretro/${_gitname}.git")
-sha256sums=('SKIP')
+depends=('gcc-libs' 'glibc' 'libretro-core-info' 'zlib')
+makedepends=('git' 'libchdr' 'libvorbis')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ "$_pkgname::git+$url.git"
+ 'unbundle-libs.patch'
+)
+b2sums=(
+ 'SKIP'
+ 'de8c8053444f1dff288ee28f2e28eeee99900b5e90d03598f8b4ebf993707ee27c65ca7b8854abcac06ab356987b90586de9277d774a3557b0641fe995fe036c'
+)
pkgver() {
- cd "${_gitname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${_gitname}"
- git submodule update --init --recursive
+ cd $_pkgname
+ mv deps/{libchdr/include/dr_libs,}
+ patch -Np1 < ../unbundle-libs.patch
+ sed -i 's/-Ofast//' Makefile
}
build() {
- cd "${_gitname}"
- make
+ make -C $_pkgname
}
package() {
- install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
- install -Dm644 "${_gitname}/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- msg2 "\e[1;32mneocd requires a bunch of BIOS files placed in the libretro 'system' folder. \e[0m"
- msg2 "\e[1;32mPlease have a look at https://github.com/libretro/neocd_libretro how to accomplish this. \e[0m"
+ depends+=('libchdr.so' 'libvorbisfile.so')
+ # shellcheck disable=SC2154
+ install -D -t "$pkgdir"/usr/lib/libretro $_pkgname/neocd_libretro.so
}