summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7289822cd95d..cce32df3a928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=libretro-pcsx2
pkgname=$_pkgname-git
pkgver=r16875.7357bde45
-pkgrel=1
+pkgrel=2
pkgdesc="Sony PlayStation 2 core"
arch=('x86_64')
url="https://github.com/libretro/pcsx2"
@@ -13,6 +13,7 @@ depends=(
'gcc-libs'
'glibc'
'libaio'
+ 'libchdr'
'libpng'
'libretro-core-info'
'libzip'
@@ -25,24 +26,26 @@ depends=(
makedepends=(
'cmake'
'fast_float'
- 'ffmpeg'
'git'
- 'sdl2'
- 'soundtouch'
+ 'libgl'
+ 'libpcap'
+ 'libx11'
+ 'libxcb'
+ 'libxrandr'
)
provides=("$_pkgname=${pkgver#r}")
conflicts=("$_pkgname")
source=(
"$_pkgname::git+$url.git#branch=libretro"
'glslang::git+https://github.com/KhronosGroup/glslang.git'
- 'libchdr::git+https://github.com/rtissera/libchdr.git'
'vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git'
+ 'use-system-libs.patch'
)
b2sums=(
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
+ 'e79cd9f3b05ad7de2f0ed366dacd2b230b973704724d77cc8fa72265b783ebb644f798b491f1d84b3923d180e173b8b7ce5fe394ac275c34bc701f182f60e780'
)
pkgver() {
@@ -53,12 +56,11 @@ pkgver() {
prepare() {
cd $_pkgname
git config submodule.3rdparty/glslang/glslang.url ../glslang
- git config submodule.3rdparty/libchdr/libchdr.url ../libchdr
git config submodule.3rdparty/vulkan-headers.url ../vulkan-headers
git -c protocol.file.allow=always submodule update
+ patch -Np1 < ../use-system-libs.patch
sed -i '/ccache/d' CMakeLists.txt
sed -i '/USE_GCC/s/AND CMAKE_INTERPROCEDURAL_OPTIMIZATION//' common/CMakeLists.txt
- sed -i '/USE_SYSTEM_LIBS OFF/d' cmake/BuildParameters.cmake
}
build() {