summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3348d7d19888..ca8b227213ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=libretro-pcsx2
pkgname=$_pkgname-git
pkgver=r11710.1c0004153
-pkgrel=1
+pkgrel=2
pkgdesc="Sony PlayStation 2 core"
arch=('x86_64')
url="https://github.com/libretro/pcsx2"
license=('GPL2' 'GPL3' 'LGPL2.1' 'LGPL3')
groups=('libretro')
-depends=('fmt' 'glib2' 'libaio' 'libglvnd' 'libretro-core-info' 'systemd-libs')
-makedepends=('ccache' 'cmake' 'git' 'systemd' 'vim')
+depends=('fmt' 'glib2' 'libaio' 'libgl' 'libretro-core-info' 'systemd-libs')
+makedepends=('ccache' 'cmake' 'git' 'libglvnd' 'systemd' 'vim')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+$url.git")
@@ -22,8 +22,10 @@ pkgver() {
}
build() {
+ # https://github.com/libretro/pcsx2/commit/c7ee173a81bc03a2e4f4d496d0157645f8e5852f
cmake -S $_pkgname -B build \
-DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_LINK_WHAT_YOU_USE=TRUE \
-DLIBRETRO=ON \
-Wno-dev
cmake --build build