summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 26 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03c5dcbc1d25..2eae24f0b7d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,37 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-
-pkgname=libretro-snes9x-git
-pkgver=r1396.83c82eb
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+_pkgname=libretro-snes9x
+pkgname=$_pkgname-git
+pkgver=r2448.46f8a6b7
pkgrel=1
-pkgdesc='Super Nintendo Entertainment System core'
-arch=(x86_64)
-url='https://github.com/libretro/snes9x'
-license=(
- custom
- GPL2
- LGPL2.1
-)
-groups=(libretro-unstable)
-depends=(libretro-core-info)
-makedepends=(git)
-provides=(libretro-snes9x)
-conflicts=(libretro-snes9x)
-source=(libretro-snes9x::git+https://github.com/libretro/snes9x.git)
-sha256sums=(SKIP)
+pkgdesc="Super Nintendo Entertainment System core"
+arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
+url="https://github.com/libretro/snes9x"
+license=('custom' 'GPL3' 'LGPL2.1')
+groups=('libretro')
+depends=('gcc-libs' 'glibc' 'libretro-core-info' 'zlib')
+makedepends=('git')
+provides=("$_pkgname=1:${pkgver#r}")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd libretro-snes9x
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+prepare() {
+ sed -i 's/-O3//' $_pkgname/libretro/Makefile
}
build() {
- cd libretro-snes9x/libretro
-
- make
+ make -C $_pkgname/libretro LTO=
}
package() {
- cd libretro-snes9x/libretro
-
- install -Dm 644 snes9x_libretro.so -t "${pkgdir}"/usr/lib/libretro/
- install -Dm 644 ../LICENSE -t "${pkgdir}"/usr/share/licenses/libretro-snes9x-git/
+ cd $_pkgname
+ # shellcheck disable=SC2154
+ install -D -t "$pkgdir"/usr/lib/libretro libretro/snes9x_libretro.so
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}
-
-# vim: ts=2 sw=2 et: