summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6282a39ac22..1e76c4f39a86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=librewolf
_pkgname=LibreWolf
-pkgver=82.0.3
+pkgver=83.0
pkgrel=1
pkgdesc="Community-maintained fork of Firefox, focused on privacy, security and freedom."
arch=(x86_64 aarch64)
@@ -13,7 +13,8 @@ license=(MPL GPL LGPL)
url="https://librewolf-community.gitlab.io/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
+ 'rust<1:1.48.0' # rust 1.48.0 causes firefox / packed_simd building to fail
+ autoconf2.13 clang llvm jack gtk2 nodejs cbindgen nasm
python-setuptools python-psutil python-zstandard git binutils lld)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -22,7 +23,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
_arch_svn=https://git.archlinux.org/svntogit/packages.git/plain/trunk
-_settings_commit=8697f589a1499598b8af5df11d82b60e8c97d981
+_settings_commit=2f76ae07f7016034273f1887b7f1bedab997909c
source_x86_64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
"git+https://gitlab.com/${pkgname}-community/browser/common.git"
@@ -38,13 +39,13 @@ source_aarch64=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/
arm.patch
https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/firefox/build-arm-libopus.patch)
-sha256sums_x86_64=('4df40aecf4b71107c4816db585bcd425f093123f29d8563bc2443a8659058691'
+sha256sums_x86_64=('d69e84e8b8449f828683d274c24e03095858362bfed21b08bdd7fe715eea5398'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
'SKIP'
'SKIP'
'682bf4bf5d79db0080aa132235a95b25745c8ef944d2a2e1fed985489d894df5'
'41719289b309912c4b6bc86b41594f671427979481a90c32a9d3d0bf1cdd6d44')
-sha256sums_aarch64=('4df40aecf4b71107c4816db585bcd425f093123f29d8563bc2443a8659058691'
+sha256sums_aarch64=('d69e84e8b8449f828683d274c24e03095858362bfed21b08bdd7fe715eea5398'
'0b28ba4cc2538b7756cb38945230af52e8c4659b2006262da6f3352345a8bed2'
'SKIP'
'SKIP'
@@ -256,6 +257,9 @@ pref("spellchecker.dictionary_path", "/usr/share/hunspell");
// pref("extensions.autoDisableScopes", 11);
END
+ cd ${srcdir}/settings
+ git checkout ${_settings_commit}
+ cd ${srcdir}/firefox-$pkgver
cp -r ${srcdir}/settings/* ${pkgdir}/usr/lib/${pkgname}/
local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"