summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8494e148696a..c3eb505d2447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,24 +15,21 @@
#
pkgname=libsdrplay
-pkgver=2.09.1
+pkgver=2.10.1
pkgrel=1
pkgdesc="Modules for the SDRplay receiver"
arch=('i686' 'x86_64')
url="http://www.sdrplay.com"
-license=('custom')
+license=('custom:EULA')
depends=('libusb>=1.0')
source=("local://SDRplay_RSP_API-Linux-${pkgver}.run")
-md5sums=('6d4cc9527f763f7e9e16ccddd373a751')
+md5sums=('cb18ef3510e9b788a8d2a918e35d62c8')
prepare() {
cd ${srcdir}
msg2 "Extracting makeself archive..."
sh SDRplay_RSP_API-Linux-${pkgver}.run --tar xf
-
- msg2 "Writing license to LICENSE..."
- sed -n 's/.*\(Copyright.*\)/\1/p' mirsdrapi-rsp.h > LICENSE
}
package() {
@@ -42,13 +39,18 @@ package() {
_apivers=$(sed -n 's/export VERS="\(.*\)"/\1/p' install_lib.sh)
msg2 "API version: ${_apivers}"
- # These commands are equivalent to the scripts used in the supplied run file
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # These commands are equivalent to the scripts used in the supplied
+ # run file
+ install -D -m644 sdrplay_license.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m644 "${CARCH}/libmirsdrapi-rsp.so.${_apivers}" \
"${pkgdir}/usr/lib/libmirsdrapi-rsp.so.${_apivers}"
- install -D -m644 mirsdrapi-rsp.h "${pkgdir}/usr/include/mirsdrapi-rsp.h"
- install -D -m644 66-mirics.rules "${pkgdir}/etc/udev/rules.d/66-mirics.rules"
+ install -D -m644 mirsdrapi-rsp.h \
+ "${pkgdir}/usr/include/mirsdrapi-rsp.h"
+ install -D -m644 66-mirics.rules "\
+ ${pkgdir}/etc/udev/rules.d/66-mirics.rules"
+
cd "${pkgdir}/usr/lib"
- ln -s libmirsdrapi-rsp.so.${_apivers} libmirsdrapi-rsp.so.1
+ ln -s libmirsdrapi-rsp.so.${_apivers} libmirsdrapi-rsp.so.2
ln -s libmirsdrapi-rsp.so.${_apivers} libmirsdrapi-rsp.so
}