summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e56e1a69233..7cb8d49b0eae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,22 +8,27 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libselinux
-pkgver=3.3
-pkgrel=2
+pkgver=3.6
+pkgrel=3
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
license=('custom')
groups=('selinux')
-makedepends=('pkgconf' 'python' 'ruby' 'xz' 'swig')
-depends=('libsepol>=3.3' 'pcre')
+makedepends=('pkgconf' 'python' 'python-pip' 'python-setuptools' 'ruby' 'xz' 'swig')
+depends=('libsepol>=3.6' 'pcre2')
optdepends=('python: python bindings'
'ruby: ruby bindings')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+validpgpkeys=(
+ '63191CE94183098689CAB8DB7EF137EC935B0EAF' # Jason Zaman <perfinion@gentoo.org>
+ 'B8682847764DF60DF52D992CBC3905F235179CF1' # Petr Lautrbach <plautrba@redhat.com>
+)
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.asc}
"libselinux.tmpfiles.d")
-sha256sums=('acfdee27633d2496508c28727c3d41d3748076f66d42fccde2e6b9f3463a7057'
+sha256sums=('ba4e0ef34b270e7672a5e5f1b523fe2beab3a40bb33d9389f4ad3a8728f21b52'
+ 'SKIP'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
build() {
@@ -32,6 +37,10 @@ build() {
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
+ # Use pcre2 explicitely even though it is the default since
+ # https://github.com/SELinuxProject/selinux/commit/e0da140d82c0ebebf1060ce87d0f11276c7fc59a
+ export USE_PCRE2=y
+
export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all
@@ -40,6 +49,10 @@ build() {
}
package() {
+ provides+=(
+ libselinux.so
+ )
+
cd "${pkgname}-${pkgver}"
export DISABLE_RPM=y