summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e656b0deec0e..1a13e22558c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=libsmu-git
-pkgver=0.87.r0.gc85a022
+pkgver=1.0.1.r18.gdda38f6
pkgrel=1
pkgdesc="Software abstractions for the analog signal exploration tools."
arch=('i686' 'x86_64')
url="https://github.com/analogdevicesinc/libsmu"
license=('BSD')
depends=('libusb' 'python2')
-makedepends=('git')
+makedepends=('git' 'cmake' 'pkg-config')
source=("$pkgname::git+https://github.com/analogdevicesinc/libsmu.git")
md5sums=('SKIP')
@@ -19,6 +19,12 @@ pkgver() {
build() {
cd $pkgname
+
+ mkdir -p build && cd build
+ cmake \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ ..
+
make
}
@@ -30,10 +36,6 @@ package() {
install -m 644 LICENSE "$pkgdir"/usr/share/licenses/libsmu-git/
# Install the library
- install -d "$pkgdir"/usr/lib/
- install -m 755 libsmu.so "$pkgdir"/usr/lib/
-
- # Install the binary
- install -d "$pkgdir"/usr/bin/
- install -m 755 smu "$pkgdir"/usr/bin/
+ cd build
+ make DESTDIR="$pkgdir/" install
}