summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cee70838b1bb..96f2364f0d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
basename=libsurvive
pkgname=$basename-git
-pkgver=1695.921f772
+pkgver=2021.35f40ce
pkgrel=1
pkgdesc="Open-Source tool for working with lighthouse-based tracking data, including support for the HTC Vive, Vive Pro and Valve Index."
arch=(x86_64 i686)
@@ -10,8 +10,12 @@ depends=("hidapi" "xr-hardware" "libpcap" "lapacke" "cblas" "zlib" "libusb")
conflicts=($basename)
provides=($basename)
makedepends=("git" "cmake" "ninja")
-source=($basename::"git+https://github.com/cntools/libsurvive.git")
-sha256sums=('SKIP')
+source=($basename::"git+https://github.com/cntools/libsurvive.git"
+ cnkalman.git::"git+https://github.com/cntools/cnkalman.git"
+ cnmatrix.git::"git+https://github.com/cntools/cnmatrix.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd $basename
@@ -22,6 +26,8 @@ pkgver() {
prepare() {
cd $basename
+ git submodule update --init --recursive
+ sed "s!cnmatrix/matrix.h!cnmatrix/cn_matrix.h!g" -i tools/vive_mouse/vive_mouse.c
}
build() {