summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1785a0986401..6cbc295b9015 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,21 @@
pkgname=libtcod
pkgver=1.5.1
-pkgrel=5
+pkgrel=6
pkgdesc="Roguelike graphics/utility library"
arch=('i686' 'x86_64')
-url="http://roguecentral.org/doryen/libtcod/"
+url="https://bitbucket.org/libtcod/libtcod"
license=('BSD')
depends=('libpng' 'sdl' 'glu')
+makedepends=('mercurial')
options=(!makeflags)
-source=(http://roguecentral.org/doryen/?file_id=26
- makefile-linux64.patch)
-md5sums=('3efe844f03fa4d6fdff98aa4cc85ef3d'
- 'af563a240f9a101c105d3abb25a1f19e')
+source=("hg+https://bitbucket.org/$pkgname/$pkgname#tag=$pkgver")
+md5sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
if test "$CARCH" == x86_64; then
- patch -p0 < $srcdir/makefile-linux64.patch
make -f makefiles/makefile-linux64 clean release TEMP=$srcdir/tmp
else
make -f makefiles/makefile-linux clean release TEMP=$srcdir/tmp
@@ -31,7 +29,7 @@ package() {
mkdir -p $pkgdir/usr/lib
mkdir -p $pkgdir/usr/include/$pkgname
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
install -D -m 644 libtcod{,gui,xx}.so $pkgdir/usr/lib/
install -D -m 644 include/*.h* $pkgdir/usr/include/$pkgname/