summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebb81ead0b24..16d8524c9ec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,37 @@
_pkgname=libtorrent
pkgname=libtorrent-ps
_pkgver=0.13.6
-pkgver=1.0.r57.gb49dfe3
+pkgver=1.0.r59.gd21c734
pkgrel=1
pkgdesc='BitTorrent library written in C++ for use with rtorrent-ps'
url='https://github.com/rakshasa/libtorrent'
license=('GPL')
arch=('any')
depends=('openssl')
-makedepends=('cppunit')
provides=('libtorrent')
conflicts=('libtorrent')
source=("https://github.com/rakshasa/$_pkgname/archive/$_pkgver.tar.gz"
'lt-ps-honor_system_file_allocate_all.patch'
'lt-ps-log_open_file-reopen_all.patch'
- 'openssl-1.1.patch')
+ 'lt-open-ssl-1.1.patch'
+ 'skip-cppunit.patch')
md5sums=('8c8eaa9fa03bd113967c68eea26493e7'
'8d7f8fe5ad412bd42f2ea66131a8ce6b'
'2bfadac7770935ca98c4714c2011541a'
- '08a51eb090e49fa24a9792d39333a5ac')
+ '1fc8eca467b3e5a5b5c43bbef21f4ba8'
+ 'e142e5513fe0782b16cab1099edcec66')
prepare() {
cd "$srcdir/$_pkgname-$_pkgver"
+ LT_PATCHES=( "$srcdir"/lt-open-ssl-1.1.patch
+ "$srcdir"/skip-cppunit.patch )
+
# Patch libtorrent
- for corepatch in $srcdir/lt-ps-*_{${_pkgver},all}.patch; do
+ for corepatch in "$srcdir"/lt-ps-*_{"${_pkgver}",all}.patch "${LT_PATCHES[@]}"; do
test ! -e "$corepatch" || { msg2 "$(basename $corepatch)"; patch -uNp1 -i "$corepatch"; }
done
- # Fix build against OpenSSL 1.1
- patch -p1 -i ../openssl-1.1.patch
-
./autogen.sh
}