summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8240a7815ff..488c1595cd2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=libtorrent-rasterbar-1
pkgver=1.2.15
pkgrel=1
-pkgdesc="A C++ BitTorrent library that aims to be a good alternative to all the other implementations around"
-url="https://www.rasterbar.com/products/libtorrent/"
+pkgdesc="Open source C++ library implementing the BitTorrent protocol."
+url="https://libtorrent.org/"
arch=('x86_64')
license=('BSD')
depends=('boost-libs' 'openssl')
@@ -15,20 +15,20 @@ _snapshot="libtorrent-rasterbar-${pkgver}"
_archive="${_snapshot}.tar.gz"
source=("${_archive}::https://github.com/arvidn/libtorrent/releases/download/v${pkgver}/${_archive}")
-sha512sums=('c409c53ec9c299a05b51ab61d7df1209803cbd6070f0a014dd6fb42c30f6f5230ea90848330f901c61816bc70901e618409acacc95bb0e5acb7f81211d001fa2')
+sha256sums=('c8ad8638684c0a903ebabc30490079e31b1a6a638da2adec5a8bef6a0e62214b')
build() {
- mkdir -p "${srcdir}/build" && cd "$_"
+ cd "${srcdir}"
- cmake -DCMAKE_BUILD_TYPE=Release \
+ cmake -B "build" -GNinja "${srcdir}/${_snapshot}" \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-Dpython-bindings=ON \
-Dboost-python-module-name="python" \
- -Dpython-egg-info=ON \
- -GNinja "${srcdir}/${_snapshot}"
+ -Dpython-egg-info=ON
- ninja
+ ninja -C "build"
}
package() {