summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c67da4e8cb55..7c7f75f5cd6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libtorrent-rasterbar-1_1-git
-pkgver=1.1.4.r16.g50c2aee8e
-pkgrel=2
+pkgver=1.1.4.r23.g41bfd41ce
+pkgrel=1
pkgdesc="A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git branch RC_1_1)"
arch=('i686' 'x86_64')
url="http://www.libtorrent.org/"
@@ -11,22 +11,25 @@ depends=('boost-libs')
makedepends=('git' 'boost' 'python2' 'python')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
-options=('staticlibs')
+options=('staticlibs' '!strip')
source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_1')
sha256sums=('SKIP')
-prepare() {
- mkdir -p py2 py3
+pkgver() {
cd "libtorrent"
- ./autotool.sh
+ git describe --long --tags | sed 's/^[A-Za-z]*-//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
}
-pkgver() {
+build() {
cd "libtorrent"
+ ./autotool.sh
- git describe --long --tags | sed 's/^[A-Za-z]*-//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+ cd "$srcdir"
+ mkdir -p "py2" "py3"
+ _build 2
+ _build 3
}
_build() (
@@ -40,19 +43,14 @@ _build() (
CXXFLAGS="$CXXFLAGS -std=c++11" \
PYTHON="/usr/bin/python$1" \
../libtorrent/configure \
- --prefix=/usr \
- --enable-python-binding \
+ --prefix="/usr" \
--with-libiconv \
+ --enable-python-binding \
--with-boost-python="$_boost"
make
)
-build() {
- _build 2
- _build 3
-}
-
package() {
make -C py2 DESTDIR="$pkgdir" install
make -C py3 DESTDIR="$pkgdir" install