summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 266fd1933da2..a30af217ff0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
pkgname=libva-xvba-driver
pkgver=0.8.0
-pkgrel=5
+pkgrel=6
pkgdesc='XvBA backend for VA-API'
arch=(i686 x86_64)
-url=http://freedesktop.org/wiki/Software/vaapi/
+url=https://freedesktop.org/wiki/Software/vaapi/
license=(GPL)
-makedepends=(catalyst-libgl libva nvidia-cg-toolkit python2 xvba-sdk)
+depends=(catalyst-libgl)
+makedepends=(libva nvidia-cg-toolkit python2 xvba-sdk)
conflicts=(xvba-video)
source=(
http://cgit.freedesktop.org/vaapi/xvba-driver/snapshot/xvba-driver-$pkgver.tar.xz
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-libs/xvba-video/files/xvba-video-$pkgver-assert-hw_image_hooks_glx.patch
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
-https://build.opensuse.org/source/home:maxge73/xvba-video/xvba-video-h264-level51.patch
-https://build.opensuse.org/source/home:maxge73/xvba-video/xvba-video-remove-installation.patch
+https://web.archive.org/web/20150802131848/https://build.opensuse.org/source/home:maxge73/xvba-video/xvba-video-h264-level51.patch
+https://web.archive.org/web/20150802131854/https://build.opensuse.org/source/home:maxge73/xvba-video/xvba-video-remove-installation.patch
https://raw.githubusercontent.com/frugalware/frugalware-stable/2.0/source/x11-extra/$pkgname/fixes.patch
)
sha256sums=(202cabed9e256abcc24d475e04677b21b6676bfd92f7fa92c889d78b03e7366a
@@ -22,15 +23,14 @@ sha256sums=(202cabed9e256abcc24d475e04677b21b6676bfd92f7fa92c889d78b03e7366a
5e3521f6ff00b416cfcf81cf3073dcc5eb84a91712e75d42fe969524a4b32cd0
f942b9eb5e216a0b6fca5cbb1e5bc09a5b8084c9fb7ed161fae4cde0ed1605f7)
-
prepare() {
cd xvba-driver-$pkgver
- patch -Np1 < $srcdir/xvba-video-h264-level51.patch
- patch -Np1 < $srcdir/xvba-video-$pkgver-assert-hw_image_hooks_glx.patch
- patch -Np1 < $srcdir/xvba-video-remove-installation.patch
patch -Np1 < $srcdir/fixes.patch
+ patch -Np1 < $srcdir/xvba-video-$pkgver-assert-hw_image_hooks_glx.patch
patch -Np0 < $srcdir/xvba-video-fix-out-of-source-builds.patch
+ patch -Np1 < $srcdir/xvba-video-h264-level51.patch
+ patch -Np1 < $srcdir/xvba-video-remove-installation.patch
}
build() {