summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b79776f30f4c..502fd5e81cb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=libxcvt-git
_pkgname=libxcvt
-pkgver=0.1.0+2+gdb5141a
+pkgver=0.1.0+3+g69fb7bf
pkgrel=1
-pkgdesc="libxcvt is a library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator."
-arch=(any)
-url="https://gitlab.freedesktop.org/xorg/lib/libxcvt"
+pkgdesc="library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator"
+arch=(x86_64)
+url='https://gitlab.freedesktop.org/xorg/lib/libxcvt'
license=('custom')
depends=('glibc')
provides=("${_pkgname}")
@@ -14,12 +14,11 @@ source=("git+${url}.git")
b2sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/libxcvt-//g ; s/-/+/g'
+ git -C "${_pkgname}" describe --tags | sed 's/libxcvt-//g ; s/-/+/g'
}
build() {
- arch-meson $_pkgname build
+ arch-meson "${_pkgname}" build
meson compile -C build
}
@@ -28,6 +27,6 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
- install -m644 -Dt "${pkgdir}/usr/share/licenses/${_pkgname}" "${_pkgname}/COPYING"
+ DESTDIR="${pkgdir}" meson install -C build
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${_pkgname}/COPYING"
}