summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de08852d2d83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=libxvnc
+_pkgname=libXvnc
+pkgver=1.1
+pkgrel=2
+pkgdesc="X11 extention protocol library for the VNC extension"
+arch=('i686' 'x86_64')
+license=('GPL')
+url=("https://github.com/bbidulock/libxvnc")
+depends=('vncproto' 'libxext')
+source=("https://github.com/bbidulock/libxvnc/releases/download/libxvnc-1.1/libXvnc-1.1.tar.bz2")
+md5sums=('949ed624250c66f035e5e93cab06e7fc')
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="${pkgdir}" install
+}