summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f29236f3c19..b631ff3f8669 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=light-locker-git
-pkgver=1.4.0.r5.f45fdd4
+pkgver=1.7.0
pkgrel=1
pkgdesc='A simple session locker'
arch=('i686' 'x86_64')
@@ -11,9 +11,10 @@ depends=('dbus-glib' 'gtk3' 'libxss' 'libxxf86misc' 'lightdm')
makedepends=('git' 'gnome-common' 'intltool')
provides=('light-locker')
conflicts=('light-locker')
-install='light-locker.install'
-source=('git+https://github.com/the-cavalry/light-locker.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/the-cavalry/light-locker.git'
+ 'light-locker-libsystemd-login.patch')
+sha256sums=('SKIP'
+ '6645624e195f7cc114b95d323dfd55c03bbdf6b01de10e694df6a97d5ef6eeaf')
pkgver() {
cd light-locker
@@ -21,6 +22,12 @@ pkgver() {
printf "%s" "$(git describe --tags | sed 's/-/.r/; s/-g/./; s/^v//')"
}
+prepare() {
+ cd light-locker
+
+ patch -Np1 -i ../light-locker-libsystemd-login.patch
+}
+
build () {
cd light-locker