summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90bbf7f79a3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Muhammad Sayuti <muhammad.sayuti94@gmail.com>
+
+pkgname=lightdm-webkit-theme-luminos-git
+_pkgname=luminos
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Customizable LightDM Webkit Greeter Theme"
+arch=('any')
+url="https://github.com/muhammadsayuti/lightdm-webkit-theme-luminos"
+license=('GPLv2')
+depends=('lightdm' 'lightdm-webkit2-greeter')
+makedepends=('imagemagick' 'nodejs' 'npm' 'git')
+source=('git://github.com/muhammadsayuti/lightdm-webkit-theme-luminos.git')
+provides=('lightdm-webkit-theme-luminos')
+conflicts=('lightdm-webkit-theme-luminos')
+md5sums=('SKIP')
+_gitroot="git://github.com/muhammadsayuti/lightdm-webkit-theme-luminos.git"
+_pkgname="lightdm-webkit-theme-luminos"
+
+
+package()
+{
+ cd ${pkgdir}
+ mkdir -p usr/share/lightdm-webkit/themes
+ cd usr/share/lightdm-webkit/themes
+ cp -dpr --no-preserve=ownership ${srcdir}/${_pkgname} ${_pkgname}
+ msg "Removing .git files"
+ cd ${_pkgname}
+ rm -rf .git
+ rm -f .gitignore
+ echo "Removing dev files"
+ rm -rf node_modules
+ rm -rf tasks
+ rm -f package.json
+ rm -f yarn.lock
+ rm -f PKGBUILD
+ rm -f install.sh
+} \ No newline at end of file