summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d615fdabcd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=lighthouse-ethereum-bin
+pkgver=1.0.3
+_pkgname=lighthouse
+pkgrel=1
+pkgdesc='Ethereum 2.0 client'
+arch=('x86_64')
+url='https://lighthouse.sigmaprime.io/'
+license=('Apache License 2.0')
+depends=('openssl')
+provides=('lighthouse')
+conflicts=('lighthouse')
+replaces=('lighthouse')
+source=("https://github.com/sigp/lighthouse/releases/download/v${pkgver}/lighthouse-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('c1cfa0a2eced07f572e36ca00a40bdf4c55c5a8db5c602709898fdd2bc7caa0b')
+
+package() {
+ install -D -m755 "$srcdir/lighthouse" "$pkgdir/usr/bin/lighthouse"
+}