summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7108821ab5c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: lf (the_lf) <lf at lfcode dot ca>
+# Contributor: lygaret
+pkgname=lighthouse-git
+pkgrel=1
+pkgdesc='A simple scriptable popup dialog to run on X'
+pkgver=r173.a9b41fa
+arch=('any') # I haven't tested it on ARM but it most likely works
+url='https://github.com/emgram769/lighthouse'
+license=('MIT')
+depends=('libx11' 'libxcb' 'cairo')
+makedepends=('git')
+optdepends=('python2: for the included cmd.py')
+source=('git://github.com/emgram769/lighthouse.git' lighthouse-git.install)
+md5sums=('SKIP'
+ 'a661ca82623dfb7dcda2bf48ed078ebd')
+provides=('lighthouse')
+conflicts=('lighthouse') # in case someone makes a stable package
+
+pkgver() {
+ cd "lighthouse"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/lighthouse"
+ make
+}
+
+package() {
+ cd "${srcdir}/lighthouse"
+ mkdir -p ${pkgdir}/usr/{bin,share/lighthouse}
+ cp lighthouse "${pkgdir}"
+ cp -ir config/lighthouse/* "${pkgdir}/usr/share/lighthouse"
+ chmod +x ${pkgdir}/usr/share/lighthouse/cmd{,.py}
+}