summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 28 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c77c6bcc577..8250469d4a7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,43 @@
-# Maintainer: Michael Riegert <michael at eowyn net>
-# Contributor: Alad Wenter <alad@archlinux.info>
-# Contributor: Daniel Landau <daniel+aur@landau.fi>
+# Maintainer: éclairevoyant
+# Contributor: Michael Riegert <michael at eowyn net>
+# Contributor: Alad Wenter <alad at archlinux dot info>
+# Contributor: Daniel Landau <daniel+aur at landau dot fi>
# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
# Contributor: mmm
# Contributor: bslackr <brendan at vastactive dot com>
-# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Jan "heftig" Steffens <jan dot steffens at gmail dot com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
-pkgname=lightspark-git
-pkgver=0.8.3.r9.g50645853
+
+_pkgname=lightspark
+pkgname="$_pkgname-git"
+pkgver=0.8.6.1.r123.111064f9
pkgrel=1
-pkgdesc="An open source flash player implementation"
-arch=('i686' 'x86_64')
-url="http://lightspark.sourceforge.net"
-license=('LGPL3')
-depends=('boost-libs' 'glew' 'ffmpeg' 'rtmpdump' 'sdl2_mixer' 'glibmm' 'pango')
-makedepends=('git' 'cmake' 'nasm' 'llvm' 'boost')
+pkgdesc="Open source Flash player implementation"
+arch=(i686 x86_64)
+url="https://lightspark.github.io"
+license=(LGPL3)
+depends=(boost-libs glew ffmpeg rtmpdump sdl2_mixer glibmm pango)
+makedepends=(git cmake nasm llvm boost)
optdepends=('gnash-gtk: Gnash fallback support')
-provides=('lightspark')
-conflicts=('lightspark')
-source=("$pkgname::git+https://github.com/lightspark/lightspark.git")
-md5sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lightspark/$_pkgname.git")
+b2sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed -r 's/^lightspark-//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long --tags --exclude latest | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DGNASH_EXE_PATH=/usr/bin/gtk-gnash .
- make
+ cd $_pkgname
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DGNASH_EXE_PATH=/usr/bin/gtk-gnash .
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir/" install
+ make -C$_pkgname DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et: