summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99bc642f2fa8..dbb048c5a99f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=lightspeed-react-git
-pkgver=r9.e299491
-pkgrel=2
+pkgver=r31.f396a1a
+pkgrel=1
pkgdesc="React frontend for the Lightspeed project"
arch=(any)
url="https://github.com/GRVYDEV/Lightspeed-react"
@@ -12,6 +12,7 @@ optdepends=("nginx: Web Server to host the static web app")
makedepends=("npm" "git")
provides=("lightspeed-react" "lightspeed-frontend")
conflicts=("lightspeed-react" "lightspeed-frontend")
+backup=("etc/webapps/lightspeed-react/config.json")
source=("${pkgname}::git+https://github.com/GRVYDEV/Lightspeed-react.git")
sha512sums=('SKIP')
@@ -37,9 +38,12 @@ build() {
package() {
cd "$pkgname"
- install -d "${pkgdir}/usr/share/webapps/lightspeed-react/"
+ install -d "${pkgdir}/usr/share/webapps/lightspeed-react"
cp -r "build/." "${pkgdir}/usr/share/webapps/lightspeed-react"
+ install -Dm644 "build/config.json" "${pkgdir}/etc/webapps/lightspeed-react/config.json"
+ ln -sf "/etc/webapps/lightspeed-react/config.json" "${pkgdir}/usr/share/webapps/lightspeed-react/config.json"
+
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/lightspeed-react/README.md"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}