summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..079c06c63a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#Maintainer: "Kirk Gleason <kirk at kirkg dot us>"
+pkgname=lightum-git
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Lightum is a daemon to control the keyboard brightness and screen backlight on MacBook based laptops."
+arch=(i386 x86_64)
+url="https://github.com/poliva/lightum"
+license=('GPL2')
+md5sums=(SKIP)
+#source=('lightum-git::git+https://github.com/poliva/lightum.git')
+source=('lightum-git::git://github.com/poliva/lightum.git')
+pkgver() {
+ cd "$pkgname"
+ git describe --always | sed 's|v||;s|-.*||'
+}
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+check() {
+ cd "$pkgname"
+ true
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}