summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 38 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7ed5c97f2f1..cbd1b33dc15a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Connor Behan <connor.behan@gmail.com>
+# Maintainer: Alonso Rodriguez <alonsorodi20 (at) gmail.com>
+# Contributor: Connor Behan <connor.behan@gmail.com>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=lilo
pkgver=24.2
-pkgrel=2
+pkgrel=3
pkgdesc="A bootloader for Linux"
arch=('i686' 'x86_64')
url="https://alioth.debian.org/projects/lilo/"
@@ -16,7 +17,41 @@ optdepends=('perl: to use keytab-lilo')
install=lilo.install
options=('!makeflags')
source=("https://alioth-archive.debian.org/releases/lilo/Lilo/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'lilo.conf')
+ 'lilo.conf'
+ '01_makefile-adds.patch'
+ '03_keytab-lilo.8-debian-based.patch'
+ '05_readme.disk-change.patch'
+ '06_notinteractive.patch'
+ '08_small-typos-in-manpages.patch'
+ '09_fix-manpage-lilo-conf-5.patch'
+ '10_fix-manpage-lilo-conf-5.patch'
+ '11_fix-gcc-10.patch'
+ )
+
+md5sums=('fe5e8c9754cee342b958b5fcbbb6eb51'
+ 'c828942206c191242875d9b5fbeae094'
+ '3e9380373e16b930c079ad31376468d9'
+ '684ca1867c5a8ad7f6ba44f0fd92ce52'
+ '51703dc2a3784974a49d498599f3da04'
+ '4ef1ffaa647531de21b689591b38d6bd'
+ '2f0a159a767e118a76f8ffa0c7dce48f'
+ '96cfca0c181b116de256e990752f5af0'
+ 'fd26557bc2d704105369c5ad6e3cc38e'
+ '112a98527481c4d9ec8e76a0bd30af8e'
+ )
+
+prepare(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ pwd
+ patch -Np1 -i ../01_makefile-adds.patch
+ patch -Np1 -i ../03_keytab-lilo.8-debian-based.patch
+ patch -Np1 -i ../05_readme.disk-change.patch
+ patch -Np1 -i ../06_notinteractive.patch
+ patch -Np1 -i ../08_small-typos-in-manpages.patch
+ patch -Np1 -i ../09_fix-manpage-lilo-conf-5.patch
+ patch -Np1 -i ../10_fix-manpage-lilo-conf-5.patch
+ patch -Np1 -i ../11_fix-gcc-10.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -48,5 +83,3 @@ package() {
rm -rf "${pkgdir}"/etc/kernel
}
-md5sums=('fe5e8c9754cee342b958b5fcbbb6eb51'
- 'ca2d8cd9b63f11444861939b42df29c1')