summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD106
1 files changed, 48 insertions, 58 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b43e45414ca7..367fe361b402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,71 +1,61 @@
-# Contributor: Patrick McCarty <pnorcks at gmail dot com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: David Seus <cryptointerest at posteo dot de>
+# Contributor: lis
+# Contributor: Robert Kubosz <kubosz.robert@gmail.com>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+# Contributor: Robert Emil Berge <filoktetes@linuxophic.org>
pkgname=lilypond-devel
-pkgver=2.19.83
+_pkgname=lilypond
+pkgver=2.25.15
pkgrel=1
-pkgdesc="An automated music engraving system (development version)"
-arch=('i686' 'x86_64')
-url="http://lilypond.org/"
-license=('GPL')
-depends=('fontconfig'
- 'freetype2'
- 'guile1.8'
- 'pango'
- 'glib2'
- 'python2')
-makedepends=('fontforge'
- 'gsfonts'
- 't1utils'
- 'ghostscript'
- 'texlive-core'
- 'tex-gyre-fonts'
- 'texlive-langcyrillic'
- 'dblatex')
-optdepends=('extractpdfmark: for reducing the size of pdf output significantly'
- 'tk: for the gui')
-provides=("lilypond=$pkgver")
+pkgdesc="Lilypond music engraving program (development release)"
+arch=('x86_64')
+url="https://lilypond.org"
+license=('FDL1.3' 'GPL3' 'custom:OFL')
+groups=('pro-audio')
+# NOTE: use guile only with 2.24.x
+depends=('gcc-libs' 'ghostscript' 'glibc' 'gsfonts' 'guile2.2' 'guile')
+makedepends=('fontconfig' 'fontforge' 'freetype2' 'glib2' 'imagemagick' 'pango'
+'python' 'rsync' 't1utils' 'texinfo' 'texlive-core' 'tex-gyre-fonts'
+'texlive-langcyrillic' 'texlive-metapost' 'texlive-fontutils'
+'texlive-plaingeneric' 'zip')
+optdepends=(
+ 'python: for lilypond-book and other scripts'
+ 'tex-gyre-fonts: for extra fonts'
+ 'ttf-dejavu: for extra fonts'
+)
+provides=('lilypond=${pkgver}')
conflicts=('lilypond')
-source=("http://lilypond.org/downloads/sources/v2.19/lilypond-${pkgver}.tar.gz" "no_fontforge-versioncheck.patch")
-sha256sums=('96ba4f4b342d21057ad74d85d647aea7e47a5c24f895127c2b3553a252738fb3'
- 'e74391f718babb984c5f637397162cf096c4716f5b9a21346ec76035cfc80817')
+source=("https://lilypond.org/downloads/sources/v${pkgver%.*}/$_pkgname-$pkgver.tar.gz")
+sha512sums=('b6623b47527a8f38abbbf6649e03beb1886a47436f4a9a03be6dcc77d06a08676d6fd58ff89157c7b52d853dc20e8fc201fc4853ffc6b3d40903dcb765faf8a8')
+b2sums=('345c09984461ee63d5082487ac9e50e9474e20ada8dcb1ccf862ed060c3ea4d64bcfc608efcab8d8059e82187bdb7b72e43fe416c6525dc6fdc682426738ef6a')
prepare() {
- cd lilypond-$pkgver
-
- # python2 fix
- for file in $(find . -name '*.py' -print); do
- sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
- sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
- done
-
- patch -Np1 < $srcdir/no_fontforge-versioncheck.patch
- rm -rf python/out/
+ cd "$_pkgname-$pkgver"
+ autoconf --force --verbose
}
build() {
- cd lilypond-$pkgver
-
- export PYTHON="python2"
- export PYTHON_CONFIG="python2-config"
- export GUILE=/usr/bin/guile1.8
- export GUILE_CONFIG=/usr/bin/guile-config1.8
-
- ./autogen.sh --noconfigure
- [[ -d build ]] || mkdir build
- cd build
- ../configure --prefix=/usr \
- --disable-documentation
-
- # FIXME: the extra LDFLAG should not be needed;
- # this is a regression somewhere
- make
+ cd "$_pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ GUILE_FLAVOR=guile-3.0
+ make -j3
+ make -j3 bytecode
}
package() {
- cd lilypond-$pkgver/build
- make DESTDIR="$pkgdir/" \
- vimdir="/usr/share/vim/vimfiles" install
-
- rm -rf "$pkgdir"/usr/share/man
+ depends+=('libfontconfig.so' 'libfreetype.so' 'libglib-2.0.so'
+ 'libgobject-2.0.so' 'libpangoft2-1.0.so' 'libpango-1.0.so')
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" vimdir="/usr/share/vim/vimfiles" install
+ make DESTDIR="$pkgdir" install-bytecode
+ install -vDm 644 LICENSE.OFL -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 {AUTHORS,NEWS}.txt README.md \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ # delete copied fonts, they are relied upon as optdepends
+ # rm "${pkgdir}/usr/share/lilypond/${pkgver}/fonts/otf/"{C059,Nimbus,texgyre}*.otf
}