summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9fd253a682d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=linadblock-git
+pkgver=0.1.r0.g513c496
+pkgrel=1
+pkgdesc="linadblock ad blocker uses hosts"
+arch=('any')
+url="https://github.com/Nefelim4ag/linadblock.git"
+license=('GPL3')
+depends=('systemd' 'bash')
+makedepends=('git')
+source=("$pkgname"::'git://github.com/Nefelim4ag/linadblock.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname}/"
+ ./install.sh PREFIX="$pkgdir"
+}