summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b953e5e3cce..60eb3fcdb033 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
_name=LinkChecker
pkgname=linkchecker
-pkgver=10.2.0
-pkgrel=2
+pkgver=10.2.1
+pkgrel=1
pkgdesc="check links in web documents or full websites"
arch=('any')
url="https://github.com/linkcheck/linkchecker"
license=('GPL2')
-depends=('python-beautifulsoup4' 'python-dnspython' 'python-requests')
-makedepends=('python-hatch-vcs' 'python-hatchling' 'python-installer' 'python-polib')
+depends=('python>=3.7' 'python-beautifulsoup4>=4.8.1' 'python-dnspython>=2.0' 'python-requests>=2.20')
+makedepends=('python-hatch-vcs' 'python-hatchling>=1.8.0' 'python-installer' 'python-polib')
optdepends=('python-argcomplete: For command-line completion')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('943a3f3f30279fbb85fc6f0569d808cf1ae4be0de4c2050c6f713429b8e58b59')
+b2sums=('ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549')
build() {
cd $pkgname-$pkgver
@@ -24,5 +24,4 @@ build() {
package() {
cd $pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}