summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60eb3fcdb033..da0d790c9f99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,20 @@
_name=LinkChecker
pkgname=linkchecker
-pkgver=10.2.1
+pkgver=10.3.0
pkgrel=1
pkgdesc="check links in web documents or full websites"
arch=('any')
url="https://github.com/linkcheck/linkchecker"
license=('GPL2')
-depends=('python>=3.7' 'python-beautifulsoup4>=4.8.1' 'python-dnspython>=2.0' 'python-requests>=2.20')
-makedepends=('python-hatch-vcs' 'python-hatchling>=1.8.0' 'python-installer' 'python-polib')
-optdepends=('python-argcomplete: For command-line completion')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-b2sums=('ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549')
+depends=('python>=3.8' 'python-beautifulsoup4>=4.8.1' 'python-dnspython>=2.0' 'python-requests>=2.20')
+makedepends=('python-hatch-vcs' 'python-hatchling>=1.8.0' 'python-installer' 'python-polib' 'python-setuptools-scm>=7.1.0')
+optdepends=(
+ 'python-argcomplete>=1.8.1: For command-line completion'
+ 'python-pdfminer>=20181108: For reading PDF files'
+)
+source=("$url/archive/v$pkgver.tar.gz")
+b2sums=('2ddf216742df3200e740032b55e6349bc45ae1ae87560595f55153737a17975659dace1c5521cb7c211ec9b64323bc3a1afc7e214a538e9eb05ef4a6d1101365')
build() {
cd $pkgname-$pkgver