summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3722e98e6e03..8ddfbd0f78c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,24 @@
pkgname=linode-cli
pkgver=1.4.7
-pkgrel=1
+pkgrel=2
pkgdesc='A simple command-line interface to the Linode platform'
url='https://github.com/linode/cli'
license=('GPL2')
arch=('any')
depends=('perl-try-tiny' 'perl-libwww' 'perl-json' 'perl-crypt-ssleay'
'perl-mozilla-ca' 'perl-webservice-linode')
-makedepends=('git')
-source=("$pkgname::git+https://github.com/linode/cli.git#tag=v$pkgver")
-sha256sums=('SKIP')
+install=linode-cli.install
+source=("$url"/archive/v"$pkgver".zip)
+sha256sums=('776a7df7eb4e595fb246b9482c3de2661ec7ff11b35156c870e78ca49ce38c07')
build() {
- cd "$pkgname"
+ cd "cli-$pkgver"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
package() {
- cd "$pkgname"
+ cd "cli-$pkgver"
make install DESTDIR="$pkgdir"
}