summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD103
1 files changed, 94 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03c43af14581..f418a28a0996 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,118 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=linphone-desktop-all-git
-pkgver=4.1.1.r522.578e1a27
-pkgrel=4
+pkgver=4.1.1.r525.b717d2ed
+pkgrel=1
pkgdesc="A free VoIP and video softphone based on the SIP protocol (Installed in /opt with all deps included)."
arch=("x86_64")
url="https://www.${pkgname%-desktop-all-git}.org/"
license=("GPL2")
-depends=("qt5-base" "qt5-graphicaleffects" "qt5-quickcontrols" "qt5-quickcontrols2" "qt5-svg" "qt5-tools")
+depends=("qt5-graphicaleffects" "qt5-quickcontrols" "qt5-quickcontrols2" "qt5-svg" "qt5-tools")
makedepends=("cmake" "doxygen" "git" "graphviz" "ladspa" "nasm" "python-pystache" "yasm")
conflicts=("${pkgname%-all-git}")
-source=("${pkgname%-all-git}::git://git.${pkgname%-desktop-all-git}.org/${pkgname%-all-git}"
+source=("${pkgname%-all-git}::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/${pkgname%-all-git}"
+ "bcg729::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/bcg729.git"
+ "bcmatroska2::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/bcmatroska2.git"
+ "bctoolbox::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/bctoolbox.git"
+ "bcunit::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/bcunit.git"
+ "belcard::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/belcard.git"
+ "belle-msrp::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/belle-msrp.git"
+ "belle-sip::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/belle-sip.git"
+ "belr::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/belr.git"
+ "bzrtp::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/bzrtp.git"
+ "cmake-builder::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/${pkgname%-desktop-all-git}-cmake-builder.git"
+ "bv16-floatingpoint::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/bv16-floatingpoint.git"
+ "ffmpeg::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/ffmpeg.git"
+ "gsm::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/gsm.git"
+ "libjpeg-turbo::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/libjpeg-turbo.git"
+ "libvpx::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/libvpx.git"
+ "libxml2::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/libxml2.git"
+ "libxsd::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/libxsd.git"
+ "mbedtls::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/mbedtls.git"
+ "minizip::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/minizip.git"
+ "openh264::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/openh264.git"
+ "opus::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/opus.git"
+ "soci::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/soci.git"
+ "speex::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/speex.git"
+ "srtp::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/srtp.git"
+ "v4l-utils::git+https://gitlab.linphone.org/BC/public/external/v4l-utils.git"
+ "xerces-c::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/xerces-c.git"
+ "zlib::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/zlib.git"
+ "${pkgname%-desktop-all-git}::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/${pkgname%-desktop-all-git}.git"
+ "mediastreamer2::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/mediastreamer2.git"
+ "msamr::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/msamr.git"
+ "msopenh264::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/msopenh264.git"
+ "mssilk::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/mssilk.git"
+ "mswasapi::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/mswasapi.git"
+ "mswebrtc::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/mswebrtc.git"
+ "msx264::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/msx264.git"
+ "ortp::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/ortp.git"
+ "webrtc::git+https://gitlab.${pkgname%-desktop-all-git}.org/BC/public/external/webrtc.git"
"${pkgname%-desktop-all-git}.desktop"
"${pkgname%-all-git}-submodules.patch")
sha256sums=("SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP"
"346d983f503873811b3a4f72772e5afe4990275526c9e15c1b5cde2ad69a0544"
- "8567795fb402655fb4a86efdbe6a14c2d071b3d15a3b9e0ca4946eb128226a74")
+ "c7971bd9866873218a429fb41ed0ce320513d34cf715d7b9967f67b4485fe2a0")
prepare() {
cd "${srcdir}/${pkgname%-all-git}"
- git submodule sync
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.submodules/bcg729.url "${srcdir}/bcg729"
+ git config submodule.submodules/bcmatroska2.url "${srcdir}/bcmatroska2"
+ git config submodule.submodules/bctoolbox.url "${srcdir}/bctoolbox"
+ git config submodule.submodules/bcunit.url "${srcdir}/bcunit"
+ git config submodule.submodules/belcard.url "${srcdir}/belcard"
+ git config submodule.submodules/belle-msrp.url "${srcdir}/belle-msrp"
+ git config submodule.submodules/belle-sip.url "${srcdir}/belle-sip"
+ git config submodule.submodules/belr.url "${srcdir}/belr"
+ git config submodule.submodules/bzrtp.url "${srcdir}/bzrtp"
+ git config submodule.submodules/cmake-builder.url "${srcdir}/cmake-builder"
+ git config submodule.submodules/externals/bv16-floatingpoint.url "${srcdir}/bv16-floatingpoint"
+ git config submodule.submodules/externals/ffmpeg.url "${srcdir}/ffmpeg"
+ git config submodule.submodules/externals/gsm.url "${srcdir}/gsm"
+ git config submodule.submodules/externals/libjpeg-turbo.url "${srcdir}/libjpeg-turbo"
+ git config submodule.submodules/externals/libvpx.url "${srcdir}/libvpx"
+ git config submodule.submodules/externals/libxml2.url "${srcdir}/libxml2"
+ git config submodule.submodules/externals/libxsd.url "${srcdir}/libxsd"
+ git config submodule.submodules/externals/mbedtls.url "${srcdir}/mbedtls"
+ git config submodule.submodules/externals/minizip.url "${srcdir}/minizip"
+ git config submodule.submodules/externals/openh264.url "${srcdir}/openh264"
+ git config submodule.submodules/externals/opus.url "${srcdir}/opus"
+ git config submodule.submodules/externals/soci.url "${srcdir}/soci"
+ git config submodule.submodules/externals/speex.url "${srcdir}/speex"
+ git config submodule.submodules/externals/srtp.url "${srcdir}/srtp"
+ git config submodule.submodules/externals/v4l-utils.url "${srcdir}/v4l-utils"
+ git config submodule.submodules/externals/xerces-c.url "${srcdir}/xerces-c"
+ git config submodule.submodules/externals/zlib.url "${srcdir}/zlib"
+ git config submodule.submodules/${pkgname%-desktop-all-git}.url "${srcdir}/${pkgname%-desktop-all-git}"
+ git config submodule.submodules/mediastreamer2.url "${srcdir}/mediastreamer2"
+ git config submodule.submodules/msamr.url "${srcdir}/msamr"
+ git config submodule.submodules/msopenh264.url "${srcdir}/msopenh264"
+ git config submodule.submodules/mssilk.url "${srcdir}/mssilk"
+ git config submodule.submodules/mswasapi.url "${srcdir}/mswasapi"
+ git config submodule.submodules/mswebrtc.url "${srcdir}/mswebrtc"
+ git config submodule.submodules/msx264.url "${srcdir}/msx264"
+ git config submodule.submodules/ortp.url "${srcdir}/ortp"
+ git submodule update --init
+
+ cd "${srcdir}/${pkgname%-all-git}/submodules/mswebrtc"
+
+ git config submodule.webrtc.url "${srcdir}/webrtc"
+ git submodule update --init
+
+ cd "${srcdir}/${pkgname%-all-git}"
+
+ patch -Np1 -i "../${pkgname%-all-git}-submodules.patch"
#Patch generated via:
#git diff --ignore-submodules > ../submodules.patch
#git submodule --quiet foreach --recursive 'git diff --src-prefix=a/${name}/ --dst-prefix=b/${name}/' >> ../submodules.patch
-
- patch -Np1 -i "../${pkgname%-all-git}-submodules.patch"
}
pkgver() {