summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 18 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83921d5466ac..fa62c470252d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,9 @@
pkgbase=linux-acs-manjaro
pkgname=('linux-acs-manjaro' 'linux-acs-manjaro-headers')
_kernelname=-ACS-MANJARO
-_basekernel=5.15
-_basever=515
-pkgver=5.15.16
+_basekernel=5.16
+_basever=516
+pkgver=5.16.2
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -37,25 +37,15 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
'config'
# ARCH Patches
'0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch'
- '0002-PCI_Add_more_NVIDIA_controllers_to_the_MSI_masking_quirk.patch'
- '0003-iommu_intel_do_deep_dma-unmapping_to_avoid_kernel-flooding.patch'
- '0004-cpufreq_intel_pstate_ITMT_support_for_overclocked_system.patch'
- '0005-Bluetooth_btintel_Fix_bdaddress_comparison_with_garbage_value.patch'
- '0006-lg-laptop_Recognize_more_models.patch'
+ '0002-Btintel_Fix_bdaddress_comparison_with_garbage_value.patch'
# MANJARO Patches
'0101-i2c-nuvoton-nc677x-hwmon-driver.patch'
-# '0102-iomap-iomap_bmap-should-accept-unwritten-maps.patch'
- '0103-futex.patch' # https://github.com/sirlucjan/kernel-patches
- '0104-revert-xhci-Add-support-for-Renesas-controller-with-memory.patch'
'0105-quirk-kernel-org-bug-210681-firmware_rome_error.patch'
- '0108-drm_i915_Add_workaround_numbers_to_GEN7_COMMON_SLICE_CHICKEN1_whitelisting.patch::https://patchwork.freedesktop.org/patch/463650/raw/'
- # Lenovo + AMD
- '0201-lenovo-wmi2.patch'
- # other patches
# Bootsplash
- '0301-revert-fbcon-remove-now-unusued-softback_lines-cursor-argument.patch'
- '0302-revert-fbcon-remove-no-op-fbcon_set_origin.patch'
- '0303-revert-fbcon-remove-soft-scrollback-code.patch'
+ '0301-revert-garbage-collect-fbdev-scrolling-acceleration.patch'
+ '0302-revert-fbcon-remove-now-unusued-softback_lines-cursor-argument.patch'
+ '0303-revert-fbcon-remove-no-op-fbcon_set_origin.patch'
+ '0304-revert-fbcon-remove-soft-scrollback-code.patch'
'0401-bootsplash.patch'
'0402-bootsplash.patch'
'0403-bootsplash.patch'
@@ -69,22 +59,16 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
'0411-bootsplash.patch'
'0412-bootsplash.patch'
'0413-bootsplash.gitpatch'
+ # ACS override patch
'0999-acs.gitpatch')
-sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
- '0817171996521675b3c1130568503f08d8b1672c955cc842200a21bf5914cd95'
- '93320dbe5928e51fb777a4f13dd9a7364eb150d7983073f7dc159e89a6ffa747'
+sha256sums=('027d7e8988bb69ac12ee92406c3be1fe13f990b1ca2249e226225cd1573308bb'
+ '3a09c2f1ad410c09cf03921abeed1a6ca7c38138fb508171ee673d429d179171'
+ 'cb2d729cc20743014d9e3bd08facb9f5bdd19d9fa89014f415c61b4a6eb78e97'
'986f8d802f37b72a54256f0ab84da83cb229388d58c0b6750f7c770818a18421'
- 'e2823eff3355b7c88a3fa327ea2f84f23cbd36569e0a5f0f76599023f63a52ca'
- 'ce53090a4572cd6162d22225113082f7e4df5028a1230529d170460e26dcf849'
- 'ab0360eac59329eb84f028c2f402ee4a17e4b3dfacb7957355e6178d35af87b9'
- '76701599bbafa49b90ccb073ef29ce2dc3731566e8fa852bd1e9e7796e184754'
- 'a2a0a0542055a6a921542fbb05cedb6eb6f3d3fb0c038bfb2304bfd3931a0f71'
+ 'b89188b1bc3516d54965dd36def6a2af3d81379e53ff7e527bbd91f77c6f191b'
'7823d7488f42bc4ed7dfae6d1014dbde679d8b862c9a3697a39ba0dae5918978'
- '844e66a95d7df754c55ac2f1ce7e215b1e56e20ca095462d926a993d557b20e0'
- 'd9330ea593829a6ef3b824db9570253280cbff7da2b4beb47cbc037824d1a29b'
'5e804e1f241ce542f3f0e83d274ede6aa4b0539e510fb9376f8106e8732ce69b'
- 'e8e6120035977903a7117ba215809b9b162b64a789848107513f219180baaada'
- '1d58ef2991c625f6f0eb33b4cb8303932f53f1c4694e42bae24c9cd36d2ad013'
+ '365d4225a7db60bd064ebbc34ce0ae582a0c378ad6c4cec7960a5ae4641a6757'
'2b11905b63b05b25807dd64757c779da74dd4c37e36d3f7a46485b1ee5a9d326'
'94a8538251ad148f1025cc3de446ce64f73dc32b01815426fb159c722e8fa5bc'
'1f18c5c10a3c63e41ecd05ad34cd9f6653ba96e9f1049ce2b7bb6da2578ae710'
@@ -101,7 +85,7 @@ sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
'27471eee564ca3149dd271b0817719b5565a9594dc4d884fe3dc51a5f03832bc'
'60e295601e4fb33d9bf65f198c54c7eb07c0d1e91e2ad1e0dd6cd6e142cb266d'
'035ea4b2a7621054f4560471f45336b981538a40172d8f17285910d4e0e0b3ef'
- '6d6b327ec7c7798f628f98ab964f4457d3cf043bad2632eb8f27548478a83cc1')
+ '2542b5cea79ab5817ce3d30c54acd045966b9c14587bfb0b2f50d473da48a1d5')
prepare() {
cd "linux-${_basekernel}"
@@ -237,6 +221,9 @@ package_linux-acs-manjaro-headers() {
# add objtool for external module building and enabled VALIDATION_STACK option
install -Dt "${_builddir}/tools/objtool" tools/objtool/objtool
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "${_builddir}/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+
# remove unneeded architectures
local _arch
for _arch in "${_builddir}"/arch/*/; do