summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a363cbd9ece..ec765deffc6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,7 @@ pkgver=5.12.r984749.6e80fb8ab04f
_product="${pkgbase%-git}"
_kernel_rel=5.12
_branch=drm-next-${_kernel_rel}
-_base="${pkgbase//-/_}"
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://gitlab.freedesktop.org/drm/amd'
license=(GPL2)
@@ -44,7 +43,7 @@ prepare() {
echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
- echo "${_base#linux}" > localversion.20-pkgname
+ echo "${pkgbase#linux}" > localversion.20-pkgname
local src
for src in "${source[@]}"; do
@@ -87,7 +86,7 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
- echo "$_base-${arch[1]}" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install