summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 20 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c5f3a355e72..4185714c52a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,11 +13,14 @@ _kernel_rel=5.4
_branch=drm-next-${_kernel_rel}-wip
_kernelname=${pkgbase#linux}
pkgver=5.3.843232.7a83645ac0cc
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://cgit.freedesktop.org/~agd5f/linux/'
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git)
+makedepends=(
+ xmlto kmod inetutils bc libelf git python-sphinx python-sphinx_rtd_theme
+ graphviz imagemagick git
+)
options=('!strip')
source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}"
config # the main kernel config file
@@ -26,10 +29,10 @@ source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}
linux.preset # standard config files for mkinitcpio ramdisk
)
sha256sums=('SKIP'
- '04c517b92f84c1c2bde2a73b63584449642a9e0d8b3074d3d9ade2ca779c476a'
- 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
+ 'c405c700b2cb06c4ec805b7e327d0b66416395995519281194a8293da69b398a'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '997dd1ca5c59e526a35d8367e6371a68406b1a58b90006e6f85d59a580c7503f')
+ '834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
pkgver() {
cd "${_srcname}"
local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
@@ -69,9 +72,7 @@ prepare() {
build() {
cd $_srcname
-#mainline: disabled for 5.1-rc5
-#make bzImage modules htmldocs
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
@@ -222,19 +223,17 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- #mainline: disabled for 5.1-rc5
-
- #msg2 "Removing doctrees..."
- #rm -r "$builddir/Documentation/output/.doctrees"
-
- #msg2 "Moving HTML docs..."
- #local src dst
- #while read -rd '' src; do
- #dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- #mkdir -p "${dst%/*}"
- #mv "$src" "$dst"
- #rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- #done < <(find "$builddir/Documentation/output" -type f -print0)
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"