summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8da9cd7f3621..84cee1cc8cf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,8 +18,8 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
"${pkgbase}.preset"
# linux package install directives for pacman
'linux.install'
- # patch from our gentoo overlords
- '5010_enable-cpu-optimizations-universal.patch'
+ # patch from our graysky archlinux colleague
+ 'https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/master/more-uarches-for-kernel-5.8+.patch'
)
sha256sums=('SKIP'
#config.x86_64
@@ -28,7 +28,7 @@ sha256sums=('SKIP'
'60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c'
#linux install file
'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
- #gentoopatch
+ #grayskypatch
'fa6cee9527d8e963d3398085d1862edc509a52e4540baec463edb8a9dd95bee0'
)
@@ -54,7 +54,7 @@ prepare() {
msg2 "Implementing custom kernel patches"
while read patch; do
echo "Applying $patch"
- git apply $patch || echo "ERROR: something went wrong with $patch. Advancing anyway."
+ git apply $patch || exit 2
done <<< $(ls ../*.patch)
# get kernel version