summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 193a81452c3c..05daec5ea6d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Steven De Bondt <egnappah at gmail dot com>
+# Maintainer: Armin Fasold <aur at bebna dot de>
+# Contributor: Steven De Bondt <egnappah at gmail dot com>
pkgbase=linux-amd-znver3
_srcname=linux
-gitver=v6.8.8
+gitver=v6.9.1
patchver=20240221.2
patchname=more-uarches-for-kernel-6.8-rc4+.patch
-pkgver=6.8.v.8
+pkgver=6.9.v.1
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -16,14 +17,10 @@ options=('!strip')
source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=$gitver"
# the main kernel config files
'config.x86_64'
- # patch from our graysky archlinux colleague
- "https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/$patchver/$patchname"
)
sha256sums=('SKIP'
#config.x86_64
- '0522a3d52716d2b74324824ea15fe768a91bf738f0c38f624f2febef98591ceb'
- #grayskypatch
- 'd69232afd0dd6982ae941cf2d1f577f4be2011e3bb847d1db37952acf416b5d3'
+ '50a7ee4b208a6396dd96e01b3c0ae7d920485c44115a7f7191f8c4c5b8e8d4ad'
)
_kernelname=${pkgbase#linux}
@@ -41,13 +38,6 @@ prepare() {
exit 2
fi
- # Implement all packaged patches and reverts.
- msg2 "Implementing custom kernel patches/reverts"
- while read patch; do
- echo "Applying $patch"
- git apply $patch || exit 2
- done <<< $(ls ../*.patch)
-
# get kernel version
msg2 "Preparing kernel"
yes "" | make prepare
@@ -67,7 +57,9 @@ build() {
cd "${_srcname}"
#Force zenv3 architecture optimisation and other optimisations.
- make ${MAKEFLAGS} LOCALVERSION= bzImage modules KCFLAGS="-O2 -pipe -march=znver3 -mtune=znver3 -fstack-protector-strong"
+ export KCFLAGS=' -march=znver3 -mtune=znver3 -O2 -pipe -fstack-protector-strong'
+ export KCPPFLAGS=' -march=znver3 -mtune=znver3'
+ make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}
_package() {