summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c67fa50abdd5..7a4e731fffe5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,7 +63,7 @@ _localmodcfg=
pkgbase=linux-bcachefs-git
_srcver_tag=5.2.18-arch1
pkgver=${_srcver_tag//-/.}
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://github.com/koverstreet/bcachefs"
license=(GPL2)
@@ -187,12 +187,14 @@ _package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules $_pkgdesc_extra"
depends=(
coreutils
- linux-firmware
kmod
- mkinitcpio
+ initramfs
bcachefs-tools-git
)
- optdepends=("crda: to set the correct wireless channels of your country")
+ optdepends=(
+ "crda: to set the correct wireless channels of your country"
+ "linux-firmware: firmware images needed for some devices"
+ )
provides=("$pkgbase=$pkgver")
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -208,6 +210,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install